Hi, how can we help?

How do I know if my phone is compatible?

The Lively Connect application requires iOS 14.0 or Android 9.0 at a minimum. Please visit our compatibility page for a complete list of compatible smartphones.

Was this article helpful?